Get in touch
Back
Resolved

Certchain CMS SSL Timeout

Started 7 Nov at 04:48pm UTC.

Certchain CMS
Created

Incident Summary:
On November 7 at 3:41 PM UTC, the internal SSL certificate renewal process encountered a timeout during an automated Certbot update. This caused the process to restart without retrying.

Impact:
As a result, Front Door was temporarily unable to access the affected domain until the certificate update was completed.

Resolution:
The issue was identified and resolved by November 7 at 4:35 PM UTC. The SSL renewal process has been restored, and additional safeguards have been implemented to ensure automatic retries in case of future timeouts.

Posted 7 Nov at 04:48pm UTC.